Redis 启动时的几个报警错误

redis 运维 · systemofdown · 于 6个月前 发布 · 597 次阅读

1)The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128

2)WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1‘ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1‘ for this to take effect.

解决:

临时解决: sysctl vm.overcommit_memory=1 永久解决: 针对这两个问题,都要修改/etc/sysctl.conf文件,在文件末尾加入以下两句:

net.core.somaxconn= 1024
vm.overcommit_memory = 1

不重启系统的情况下使之生效sysctl -p,查看是否生效

sysctl -a | grep net.core.somaxconn
sysctl -a | grep vm.overcommit_memory

3)WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled‘ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.

解决:其实警告信息已经说的很明白了。

临时解决:root用户执行echo never > /sys/kernel/mm/transparent_hugepage/enabled

永久解决:将上面这句话写入到/etc/rc.local文件中。

修改完成后要重启redis。

共收到 0 条回复
没有找到数据。
添加回复 (需要登录)
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册